A bővítmények nem csak új lehetőségekkel bővíthetik a WordPress oldalunkat, hanem egyben új biztonsági kockázatokkal is. Lehet maga a WordPress motor bármilyen biztonságos, ha egy bővítmény biztonsági rést nyit rajta. Ezért nagyon fontos alapelv, hogy csak azokat a bővítményeket telepítsük és használjuk, amelyekre valóban szükségünk van. Amikor döntést hozunk egy bővítmény telepítéséről, ne csak azt mérlegeljük, hogy milyen funkciókat nyújt számunkra, hanem figyeljünk oda az egyéb részletekre is: Mikor frissítették utoljára? Ki áll mögötte? Milyen egyéb referenciái vannak a szerzőnek? Mit mondanak róla a felhasználók?
Törekedjünk arra, hogy minél kevesebb kritikus funkciót bízzunk bővítményekre! Ideális esetben az oldalunk akkor is működőképes marad (még ha esetleg korlátozott kényelmi funkcionalitással és kevésbé látványos megjelenéssel), ha minden bővítményt kikapcsoltunk. Persze az ideális eset nem mindig megvalósítható, így elképzelhető, hogy az oldalunk olyan mértékben támaszkodik egy fontos bővítményre (mint amilyen például a BuddyPress), hogy annak kikapcsolása lényegében egyenlő az oldal leállításával, hiszen a felhasználók által igényelt, alapvető funkciók válnak elérhetetlenné. Ez nem feltétlen baj, de törekedjünk arra, hogy az ilyen, kritikus jelentőségű bővítmények valóban biztos hátterűek és megbízhatók legyenek. A fent említett BuddyPress például ilyen.
Gyakran előfordul, hogy egy bővítmény hivatalosan nem támogatja az általunk használt WordPress verziót, csak annál egy korábbi kiadást. A tapasztalat ugyanakkor azt mutatja, hogy az esetek túlnyomó többségében az újabb verzióval is tökéletesen együttműködik a bővítmény, így mindenképpen érdemes lehet vele egy próbát tenni, különösen akkor, ha a lemaradás nem túl jelentős. Ne hanyagoljuk el a WordPress motor biztonsági frissítését csak azért, mert az általunk használt bővítmény leírásában még nem szerepel esetleg a frissített kiadás! Az elavult, ismert biztonsági hibákkal rendelkező WordPress motor komoly kockázatot jelent. Ha azt tapasztaljuk, hogy a bővítmény nem frissül megfelelő ütemben, és már nem kompatibilis az újabb WordPress verziókkal, mindenképpen cseréljük le!

A szerzőről

Torma László

Torma László

Mi a véleményed?

Yes No